Shining Force III Translation Project
SF3 Translator Instructions
SF3Translator © 2005 Halfbit Studios
I. Required Files
SF3Translator.exe (this package) – Self extracting install. Includes the Translator program and supporting files.
SF3Patch.exe – Self extracting install. Everything needed to patch and create ISO's or game discs for SF3.
See the SF3Patch read me file for information on using the patch which is not covered in this file.
These files are available from the SF3 Translation project FTP courtesy of Moogie and Shining Force Central.
Right click and “Save Target As…” to download files. Single left click on a txt file to view.

ftp://ftp.shiningforcecentral.com/pub/sf3translation/
Depending on the task, additional files may be needed as documented in the sections below.
II. Information and Operation
The SF3 Translator program is provided for those helping with the translation project. If you simply want to apply the translation patch, this program is not necessary. If you have a needed skill and would like to help with the Translation Project, post in the SFC Translation Project forum (“Call For Help” thread) or use the contacts at the end of this file.
Open a File

Use File > Open Japanese Text to open a bin file. Files with editable text and dialog are prefixed with X5.
Example: X5SAMPLE.bin

These will be referred to as game files hereafter. These can be copied from the original game disc or downloaded from the FTP > Translation Task Files directory.
s1 Original.zip

s2 Original.zip

s3 Original.zip

pd Original.zip
Refer to the SF3 Game File List, which is also included in the SF3Translator package, for more information about game files and specific file contents.

File Layout and Navigation
Game files usually contain 8 or 9 Pages and 256 (max.) Lines per Page. The current Page and Line can be determined from the Page: and Line: readout on the top right of the program interface. The Page can be changed using the buttons below the readout. The Line can be changed by using the slider directly to the left of the buttons (or by using the Goto pulldown). The Lines themselves can be navigated using the arrow buttons directly to the left of the slider.
Great caution should be taken with the Insert and Delete keys. These keys insert or delete entire lines and move all lines below to reflect the change. For example if you navigate to line 0-10 and hit the delete key, line 0-10 will be deleted and line 0-11 will become line 0-10. 0-12 will become 0-11 and so on to the end of the page. With insert, all lines move down and the last line of data is lost. It is highly recommended that these keys not be used.

Line Display
There are 2 separate boxes that display lines. The top (Jap) box displays the contents of the compressed game file that was opened. It is recommended that the original game file be used when opening a file, since it is sometimes useful to see what is contained in the original file. The bottom (English) box displays what is currently saved in the “SF3Translator\Scripts\PATCHED INFO” directory which is the data contained in and used by the translator process. Each game (bin) file will have its own directory and each page will have its own .sf3 file. This directory will be created automatically when a game file is opened for the first time and it contains subsequent changes you make to the bottom box when the file is saved.

Saving a File

Use File > Save English Text to save the info in the bottom (English) box to the .sf3 files in the Scripts > PATCHED INFO directory.
Repeating Lines and Dialog Lines
There are a certain number of lines in each scenario that are common for all files of that type. These contain common elements of the game including the menus, weapon and item names, character and enemy names, etc. Additionally, there are a couple of standard file types for each scenario and a very few odd files. The ranges for the repeating lines and dialog lines are as follows:
Sc1 Standard Files

Repeating Lines

Dialog

III. Identifying Line Locations

The translator program and the patch can be used to replace the lines in the game files with information indicating the locations of the lines. Once the locations of dialog are known, they can be matched up with lines from the translated game script. Instructions for applying the SF3Patch and creating an ISO are contained in the SF3Patch Read Me.doc. The information in this section only covers the steps necessary to create a diagnostic ISO to be used to identify where lines are located within the game files. Note many of the steps in this section have already been done and do not need to be repeated, but are documented here for information purposes. Skip to the Creating a Diagnostic ISO section if you are not interested in the entire process.
Prepare the Directory
Backup and remove all files from the following directories:

SF3FilesPatch\compress
This directory is where the finished files will appear after compressing.

SF3FilesPatch\Scripts\PATCHED INFO
This directory stores the info contained in the bottom (english) boxes.

Once this task is complete, the diagnostic files in these directories can be archived and the previous files restored.

Inserting Line Locations
This must be done for each file in which location information will be shown (usually all). Open the game file. 

Use Fill > Fill w/ Name & Number. The bottom boxes on the current page will fill with the information. 
This must be done for each Page of the file. Use the Next Page button and repeat the Fill w/ Name & Number command until all are filled in. Save the file. Exit the file. Re-open the file and compress.
See the Creating Game Files section for instructions to create compressed game files. 

Creating a Diagnostic ISO
Rename the SF3Patch > files > sX (s1, s2, s3 or pd) directory to "sX Original" (or a name of your choosing) or otherwise make a backup. The directory used will depend on which scenario the ISO is being created for. 

Create a new sX directory and place the compressed game files containing the line location information within. Completed versions of these files are available for download from the FTP > Translation Task Files directory. 

s1 Diagnostic.zip

s2 Diagnostic.zip

s3 Diagnostic.zip

pd Diagnostic.zip
Apply the SF3Patch using these files to create a diagnostic ISO.
See the SF3Patch Read Me.doc for instructions to create an ISO or game disc using compressed game files.
Once the ISO has been created, rename the sX directory containing the diagnostic files to "sX Diagnostic" (or a name of your choosing) and rename the "sX Original" directory back to "sX". Another directory can be created to backup the diagnostic ISO itself for each scenario. Once created, it never has to be created again.
Identify Line Locations
See the SSF for SF3 Read Me.doc for instructions to run an ISO using the SSF emulator.

Once the diagnostic ISO is running in game, the line location information will appear everywhere a line is referenced. Document the line location information in menus and dialog to be used with txn files and other forms of inserting data. See Txn Files under the Inserting Data section for additional information. It is also useful for identifying problem spots during the course of the translation work.
Example of line location information seen in game:

DREAM8 50

DREAM is the file name, 8 is the page number, 50 is the line number.

IV. Inserting Data
Entering Data Manually

Text and other characters can be manually typed into the bottom (English) box. Letters (upper and lower case), numbers and most punctuation marks can be entered directly from the keyboard. The two odd input characters while using the provided english font are the close quotes, which is inserted with the @ character and the open single quote, which is inserted with the $ character.
Data from the opened game file (top box) can be copied to the windows clipboard by using the "Copy Jap to Clipboard" button on the top right just above the page number display. Likewise, data can be copied from the windows clipboard into the translator program by using the "Paste Eng to Board" button located on the bottom right. This button will also automatically insert the end line character from the opened file (top box). These buttons affect the current line only.

Other characters more specific to the game files, such as line breaks, memory items and text effects can be inserted from the various menus and the character map of the translator program and are discussed below.
Txn files
While changes can be typed directly into the translator program, they can be inserted much faster using txn files. Txn files are simply txt files with the extension changed. This was done to give the translator program a distinguishable file type. Notepad or similar should be used to view and edit txn files and should be associated with the file type. To associate txn files with Notepad, right click on a txn file and select “Open with…” In the dialog select Notepad and check the box at the bottom to “Always use the selected program to open this type of file”. Do not convert txn files to other text editor file types (such as .rtf or .doc) since they can contain formatting that can cause problems in the process. Therefore, Notepad should always be used to create and edit txn files.
Txn files must be in the format shown below

Tilde-Page Number-Dash-Line Number-Tilde-Space-Character or line description-Colon

Dialog or Text on next line

~8-205~ Campbell:

Let’s march, Prince Medion!

If additional notes are required, they can be place after the space and enclosed in tildes with an additional space before the character name.

~8-205~ ~looks at Medion~ Campbell:

Let’s march, Prince Medion!

Entries should be placed in the txn with no blank lines between them. There should be no blank lines at the beginning or ending of the file.

Use Fill > Fill from SFC Text and browse for the txn file and click Open. Always verify the lines were inserted correctly. Check the line before the first, the first, glance over the middle, the last and the line after the last to be sure the insertion was successful. If there are problems, exit the program without saving and look for errors in the format of the txn. Use File > Save English Text and exit the file. Reopen the file to continue. This is necessary to avoid a crash and in some case may need to be done immediately after inserting.

Creating and Inserting Script Files
Script (.dat) files are a little more involved to create than txn files, but contain the effects and breaks as well as the text, making them much more convenient to use. They are most often used for the file page that splits between repeating lines and dialog (page 8 for Sc. 2) and for things like shops and churches that are the same group of lines from file to file, but are located in different places. These .dat files can be viewed and associated with notepad as with the txn files, but they can’t be successfully edited in this way.

To create a script file, either open the X5DAT.bin file located in the “SF3Translator\Special Data\Dat Templates” directory and insert the data with the Translator or take an existing .sf3 page file from a correct game file in the “SF3Translator\Scripts\PATCHED INFO” to start with. Either way a .sf3 page file is needed.

If an existing game file has the correct data from the beginning of the file and the end needs to be truncated (as is the case for creating a script to insert Page 8 repeating lines 1 thru 204 while leaving the dialog lines 205-256 unchanged) then using an existing file is the way to go. If it is a smaller file and/or the data is in the middle of an existing file, it is best to use the DAT.bin Page 0 and insert the data. The idea is to get all the data at the start of the page. Additionally the DAT.bin is not an actual game file (it is simply a template), so data can be inserted and arranged here without fear of messing up an actual game file.

Take the resulting .sf3 file (either the Page 0 DAT.bin file or the existing page file) and copy it into the “SF3Translator\Special Data” directory. Also in this directory, find a couple of examples of finished .dat files and a shortcut to the XVI32 Hex Editor. Rename the .sf3 file to something meaningful and make the extension .dat instead of .sf3.

Execute the XVI32 Hex Editor and open the .dat file. Use the scroll bar and locate the last line to keep and take note of the line number on the left. Move the scroll bar all the way to the bottom. There should be a “00” entry highlighted at the very end. Hold down the backspace key to start removing the unwanted lines, stopping a couple of lines from the top. Click the down arrow on the scroll bar to move a page up and repeat until you reach the last line to keep. Notice that the highlighted “00” stays intact as you delete. This will be the last character of the file. Stop this character with one space remaining after the last character to keep.

For example, if the last character on the last line to keep is a “.” (a period is 2E in the hex editor), then the last 3 characters should be (period)(space)(highlighted space) or  2E  00  00
Save the file and exit the hex editor. The script file is ready. Verify it works as expected.

To insert a script file, navigate to the proper page and line and use Fill > Fill from ScriptFile. Script files insert reliably without problems, but unlike txn’s, they must be inserted on the correct line.

Page Migration
Page Migration involves taking the saved data from one file and inserting it into other files. This is very useful when making changes to the repeating lines as these changes usually need to be made to every file.

The data for each file is saved in the “SF3Translator\Scripts\PATCHED INFO” directory.

As a fictional example, the X5CORRECT.bin file (not an actual game file) is ready to go with all the correct lines, and those lines need to be migrated into our other files.

Go to the “SF3Translator\Scripts\PATCHED INFO\CORRECT” directory. There you will find a .sf3 file for each page of the game file. Copy the pages to be migrated (lets say 0 thru 7 for the example) into the “SF3Translator\Scripts\Page Templates” directory. Rename the page files to remove the X5CORRECT from each one leaving simply 0.sf3, 1.sf3, 2.sf3, etc according to the page numbers.

In that same directory, find the Sc2 Rename.bat file. Right click and edit this file. Verify there are both a del line and a ren line for each page being copied. These lines can be added or removed as needed.

Copy the page template files (0.sf3, 1.sf3, etc.) and the Sc2 Rename.bat file to the clipboard. Return to the “SF3Translator\Scripts\PATCHED INFO” directory and enter the directory of the game file that will receive the data. Paste the template files into the directory.

Again right click on the Sc2 Rename.bat file and edit. Enter the name of the file to be changed on the first line after the X5. Take care to only enter the file name and not the page number or extension. The file name is also the name of the directory. Use File > Save and exit the .bat file.

Execute the Sc2 Rename.bat file. This will delete the old pages and replace them with the new pages. All that is left to do is open the .bin file with the Translator and Compress!!!. With the template files still on the clipboard, other files can be done immediately.

V. Inserting Effects
Character Map
Most any text character the game files use can be inserted from the SF3 Text Characters pulldown. Make a selection quickly as the program will exit if the character map is displayed for approx. 5 seconds. The Character Map can be closed safely by using ESC. Additionally, most effects can be inserted from the various pulldowns featured in the translator program as described below. Using a pulldown is generally more convenient that the Character Map, but some effects are only available here.

Determine Line Break Locations

Before New Lines and End Line Breaks can be added, the locations of such breaks need to be determined.

Create a Word .doc file called “filename breaks” (or a name of your choosing). It is convenient to keep them with the txn files. Use the default 12 point Times New Roman font. This font is very similar to the provided english font. If other languages or fonts are used, a font with a similar width should be use for this purpose.
Open the completed txn file and use Edit > Select All, then copy the entire contents of the txn file into the doc file. In Word, use Edit > Select All. Drag the right indent (on the right side of the measure bar) left to the 2½” mark. This is the approximate width the dialog lines need to be.

The next step is easier if you separate the number/character lines and actual dialog lines as you go. A blank line on top and bottom of each line of dialog will isolate it enough to get a good visual representation of what the line will look like in the game. As you are going through each line, try to make it look as uniform and presentable as possible.

With the cursor at the beginning of the first line of dialog, freely move the right indent to achieve visually uniform lines. Do not go over 2 3/4” unless the line is very long and lines up perfectly at 2 7/8”. A perfect dialog entry lines up on the right side and has every sentence on a new line. Most won’t be perfect. If given a choice, favour making the right side line up over a sentence having a new line, unless that line is of great importance. If it is a short line, but too long to fit within 2¾”, shorten the indent so the two lines are even at the end. A stair step look can also be utilized on lines which are difficult to make visually uniform.

Dialog lines should generally be no more than 5 lines to each bubble (4 is preferable). Look for ways to split up longer dialog entries, preferably using the same number of lines in each portion and separate them with an End Bubble w/ Arrow.
Adjusting the indent will sometimes be enough, but carriage returns (enter) can be used to make minor adjustments. A good amount of judgment goes into this… The goal is superior readability and visual uniformity.
Some examples:



~8-212~ Grantack:



The village chief believes there are 



people from the empire cooperating 



with Bulzome. So, that's why he 



believes we are his enemies as well...



~8-209~ Syntesis:



They certainly haven't



welcomed our arrival…

Lines which are questions will require additional consideration. Make a determination if the actual question needs to split from the rest of the dialog line by a button push in game. Usually if the line is short and/or if the question takes the whole line, it will not be split. If there is a long sentence explaining the situation and then an additional question sentence at the end, you may want to split them. For this step, just know that if you decide to split the line, the question sentence will start on a new line and a new text bubble in game. It will also be helpful to mark a line with a question as to be easily recognizable when you insert the breaks since question require a different end line break (~8-209~ ~Question~ Syntesis:).

Once all the lines look as they should look in the game, it is time to actually insert the line breaks.
Inserting New Lines and End Line Breaks
Open the game file in the translator and navigate to the lines in the doc file and the translator. Use the Effects > Carriage Return > New Line command to add line breaks everywhere a line ends in the doc file. Remove the space between the words where the line break is added.

At the end of the dialog line, use the Effects > Carriage Return > End Bubble w/o Arrow command to insert the need for a button push (without the arrow effect) to end the dialog line.

In general, you should match whatever is at the end of the original file.

Use an End Bubble w/ Arrow when the same person has consecutive lines of dialog, to separate a long entry that has been split or anywhere the arrow effect is desired.

For question lines, insert a Memory 1E at the end of the question to enable a button push with the arrow effect for the input prompt. If you decide to split a question away from a large line, insert an End Bubble w/ Arrow before the question sentence.
Memory Items
The game uses memory items to insert some elements of the text and dialog. These include names of characters, items, spells, etc. Character Names can be inserted from the Insert Name pulldown.

Other memory items can be inserted from the Contents grabbed from RAM pulldown.
Memory Item


Use
Slot 1 (mem10)
=
Hero Name

Slot 2 (mem11)
=
Names and Combos

Slot 3 (mem12)
=
Characters

Slot 4 (mem13)
=


Slot 5 (mem14)
=
Items
Slot 6 (mem15)
=
Spells
Slot 7 (mem16)
=
Number (coins, exp., level) 
Slot 8 (mem17)
=


Slot 9 (mem18)
=
Special Attacks
Slot 10 (mem19)
=
Friendship
Slot 11 (mem1a)
=
First 2 letters of sc3 heros name, first letter of sc2 heros name, and first 2 letters 




of sc1 heros name

Slot 12 (mem1b)
=


Slot 13 (mem1c)
=
optional “'s or ‘” in english Sc1
Slot 14 (mem1d)
=
optional “s” in english Sc1
Slot 15 (mem1e)
=
Used for input prompt
Slot 16 (mem1f)
=

Pauses
Pauses in dialog can be inserted by using the character map and selecting the following:

Character

Effect
05

=
short pause (usually used after ...)

06

=
long pause

07

=
longer pause (also used to terminate all other effects)

Brief Pause
=
longer pause

Text Color
Text color can be added by using the Color pulldown. The color effect uses a combo consisting of the Color # (08) character and one character following it that determines the color used. A white or an "07" will need to be inserted to terminate the color. For any colors above 15, the combo will have to be entered manually.
Color #
Combo Character

Color Used
1

End Bubble w/ Arrow

Dark Gray

2

End Bubble w/o Arrow
Blue
3

End Line


Dark Red

4

Brief Pause


Light Red

5

05



Green

6

06



Light Blue

7

07



Yellow

8

08 Color


White

9

09 Font Style


Black

10

0A Font Size


Medium Red

11

0B Tilt



Purple

12

0C Zoom


Gray Green

13

0D



Brown

14

0E Tab



Medium Green

15

0F Other Effect

Light Gray
16

(mem10)


Gray (used for whispering)

24

(mem18)


Rainbow flashing (used for Soulmate friendship)
Font Size

Font Size can be adjusted by using the Effects > Font Size pulldown. The font size effect uses a combo consisting of the Font Size (0A) character and one character following it that determines the size used. 
The default size 1 or an "07" can be used to terminate this effect. Generally not used as the default and zoom effects work well, but it is available nonetheless.
Size #

Combo Character

Size
1

End Bubble w/ Arrow

Default

2

End Bubble w/o Arrow
1/4

3

End Line


1/2

4

Brief Pause


2/1

5

05



4/1

6

06



8/1

7

07



16/1

Font Style

Font Style can be changed by using the Effects > Font Style pulldown. The font style effect uses a combo consisting of the Font Style (09) character and one character following it that determines the style used. 

The default style 1 or an "07" can be used to terminate this effect.
Style #

Combo Character

Style Description
1

End Bubble w/ Arrow

Default

2

End Bubble w/o Arrow
Bold
3

End Line


Default with undetermined effect
4

Brief Pause


Bold with undetermined effect (used for first dialog names)
5

05



Shaking
6

06



Bold Shaking
7

07



Fast Shaking
8

08 Color


Bold Fast Shaking

9

09 Font Style


Swinging Door

10

0A Font Size


Bold Swinging Door

11

0B Tilt



Fast Swinging Door

12

0C Zoom


Bold Fast Swinging Door

13

0D



Shaking Swinging Door

14

0E Tab



Bold Shaking Swinging Door

15

0F Other Effect

Fast Shaking Swinging Door

16

(mem10)


Bold Fast Shaking Swinging Door


Zoom and Tilt (section not complete)
Text Zoom and Tilt effects can be inserted by using the Effects > Zoom and Effects > Tilt pulldowns respectively. The Zoom effect uses a combo consisting of the Zoom # (0C) character and one character following it that determines the level of zoom applied. Likewise for tilt using the Tilt # (0B) character with a combo character to determine the angle of tilt of the text (not an oblique tool). When using these effects, a small dialog appears. A number input is entered to determine the magnitude.
Zoom #
Combo Character

Magnitude






Zoom out







Default







Zoom In
Tilt #

Combo Character

Magnitude






Tilt Left







Default







Tilt Right
Tab
Tab effects can be inserted by using the Effects > Tab pulldown. The Tab effect uses a combo consisting of the Tab # # (0E) character and two characters following it that determines the effect. When using this effect, a small dialog appears. A number input is entered for each of the two characters to determine the effect.
VI. Creating Game Files

After data and effects are inserted, the saved information must then be compressed into error free files usable by the SF3Patch and the game. These game files can and should be created throughout the process in order to test their functionality and check their content.
Compress the File
Open the game file to be re-created. Use File > Compress!!!. This will create a new compressed usable game file in the “SF3Translator\compress” directory. If one or more error dialogs pop up during compression, you will need to eliminate the errors. If no error dialogs pop up, the game file size will still need to be verified. 
See Eliminate File Size Errors section below.
Eliminate Compression Errors

Compression errors are caused by too much data contained within a single line. Maximum allowed characters on an individual line vary depending upon the actual characters used, but the limit is around 215 characters. 

The recognized size of the line can't exceed 256 bytes. Some characters take up more space than others.
When errors are present, a dialog will pop up identifying the recognized line size and location. Take note of this information. Navigate to the line in question and estimate the number of characters that will need to be removed to get the offending line under the limit (actual length - 256). This will help develop the strategy for reducing it. Does it only need to shave a couple of characters or does it need an entire phrase removed?
As the lines pertain to txn files, a rough estimate of the limit is shown below. As stated this can give or take a few characters depending on the particular characters used.
************************************************************************************************************************************************************************************************************************

In a txn file, this limit applies to the actual dialog only. Neither the page and line numbers nor the speakers name count toward this limit. Make sure any notes associated with the line are between the line number and the speakers name and surrounded by ~’s. The speakers name should have a : after it.

Example before re-wording:

~8-228~ ~if Garosh lives in Scenario 1~ Young Man:

Garosh, the guard that survived the docking pier battle, originally comes from Headland. I know I'm uneasy about what the future may bring for this region, but he seems to be keen to visit his old hometown.

Creatively re-word or remove unnecessary parts of the dialog to get it below the limit, but keep the meaning of the line intact.

Example after re-wording:
~8-228~ ~if Garosh lives in Scenario 1~ Young Man:

Garosh, the guard who's originally from Headland, survived the docking pier battle. I'm uneasy about the future of this region, but he seems to be keen to visit his old hometown.

The correction can be made manually in the translator if it is small or the shortened line can be copied to the windows clipboard from the txn file and pasted into the line in the translator using the "Paste Eng to Board" button. The breaks and effects will need to be re-inserted if this method is used, but the break locations will likely need to be determined again anyway.

After the shortened line is completely re-inserted, compress the file again to verify the error is no longer present.

Eliminate File Size Errors
Once the game file will compress with no compression errors, the only thing left to check is the actual game file size which can’t exceed 64 kb. Highlight the file in explorer and either look at the file details on the left margin or right click and select properties to see the actual file size. Be sure the game file size is 63.9 kb or less or the game will contain errors when running including failure to boot. If the game file is under the size limit, this can be considered an updated file that can be used with the SF3Patch. See SF3Patch read me for additional information.

If the game file is over the size limit, some data will need to be removed to shrink the file size. There are some unnecessary lines contained in the files as well as some lines that will never be accessed by certain files that can safely be removed. Simply go to the line to be removed and backspace over the characters until the cursor is in the first box. Do not use the Delete key! As stated at the beginning of this file, this will reposition all subsequent lines on the page.
File name text that is not used by the game that can be blank in all files

Sc1
6-65 thru 6-237
Sc2
2-180 thru 3-129
Sc3
2-176 thru 3-92
Enemy names that can be removed in all non-BTL files

Sc1
4-76 thru 4-216

Sc2
5-253 thru 6-184

Sc3
6-74 thru 7-28
Once these are removed in one file, a page template can be saved and re-used utilizing the Page Migration method described previously in the Inserting Data section.
If you are really in a pinch the text that describes all the areas of the game are contained in every file. These are used by the game, but will only be accessed in areas where the file is in use. For example, all the game files that are used exclusively in Saraband don't need all the other areas of the game.

Area names that can be selectively removed in individual files as a last resort
Sc1
5-154 thru 6-64

Sc2
1-235 thru 2-168

Sc3
2-11 thru 2-175
If removing all suggested lines still leaves the game file too large, some dialog lines may need to be shaved or other lines that are not being used may need to be identified. Tread carefully in these areas.
VI. Other Modifications
Editing the Font

Scenarios 2 and 3, and the Premium Disc

This procedure will edit the SF3Translator\data\sf3-2.fon file.

This font file is used when compressing any game file from any of these 3 japanese titles.

The font characters’ look and spacing can be edited from within the translator program.

Open any Scenario 2, 3, or Premium Disc game file and Use File > Change Font to open the font editor.

Scroll through the characters with the up and down arrows.

To change the look of a character, click on the individual pixels. Black is invisible, white is visible.

The characters will generally be left justified with the spacing defined on the right. The top line of the character is used to define the spacing by entering a binary sequence in the last 4 pixels on the right of the top line. This is calculated by converting a decimal number into binary. This decimal number represents the total width minus the character width (x) minus the desired spacing (1 pixel is usually enough). (16-x-1)
This formula can be used to get a good estimate of required spacing, but additional adjustment may be needed.

The width can be entered into the font editor by placing a black pixel for 0 and a white pixel for 1.

Decimal
Binary

Spacing
Sequence

1

0001

(narrower spacing)

2

0010

3

0011

4

0100

5

0101

6

0110

7

0111

8

1000

9

1001

10

1010

11

1011

12

1100

13

1101

14

1110

15

1111

(wider spacing)

Scenario 1 (US and UK)

This procedure will create a new SF3Translator\data\sf3-1.fon file using the sf3-2.fon file and a conversion tool. This font file is used when compressing any game file from Scenario 1. Keep in mind only the US and UK versions of Scenario 1 work with the SF3Patch and the font needed for Scenario 1 is a slightly different format from the font used in the Japanese titles. It can't be edited within the Translator program directly.
This assumes the sf3-2.fon file has been edited as described above and is working perfectly. Make a copy of the sf3-2.fon file within the SF3Translator\data folder. This will be the backup that will ultimately be the actual sf3-2.fon file. Edit the original sf3-2.fon file using the procedure above. This file will become the sf3-1.fon file. Decrease the spacing of every character by one decimal spacing. For example: If the spacing for a given character in Scenario 2 was 5 (0101), in Scenario 1 it will need to be 4 (0100). This should be the only difference in the font spacing, but additional adjustment may be required.

Once the file has been edited for Scenario 1 use, move it to the SF3Translator\Tools\SF3FontFixer directory. Drag the sf3-2.fon file onto the SF3FontFixer.exe and two files will be created. The sf3-1newJ.fon file will not be used and can be deleted. Rename sf3-1newU.fon to sf3-1.fon and place it in the SF3Translator\data directory. This is the scenario 1 font file. Rename the scenario 2 font file copy back to sf3-2.fon.
Editing Game Images
The title screen, the chapter titles, and other game images exist as .SPR game files. In order to edit them, they must be converted into a format that image editing software can recognize (BMP). After editing, they must be converted back to .SPR files to include with the rest of the edited game files used by the SF3Patch.
The image converter tool must be executed from a dos command line with the proper syntax and parameters.

In windows, click Start > Run... In the Run dialog type cmd in the Open box and click OK. The command dialog will open and a dos prompt will be waiting for input. Make the SF3ImageConv directory the current directory by typing the following, taking care to include the space after cd (change directory) and to replace the file path with your particular file path. Dos commands are not case sensitive.
cd c:\sf3translator\tools\sf3imageconv
(enter)
This will be the file path if the SF3Translator package was installed directly to the C drive which is the default. Note that file paths with spaces are not allowed in dos commands (without quotations), so if you have that condition or the translator package was installed deep in many directories, you may opt to simply move the SF3ImageConv folder to C and use the c:\sf3imageconv file path.

Once the SF3ImageConv folder is the current directory, the conversion programs can be run by typing their name and the required parameters separated by spaces. The proper syntax are as follows:
To convert an SPR file to a BMP file

bintobmp <image name>.spr <image width> <image height>
Where bintobmp is the executable name, <image name> is the name of the image, <image width> is the width of the image in pixels, and <image height> is the height of the image in pixels.

To convert a BMP file to an SPR file

bmptobin <image name>.bmp
Where bmptobin is the executable name and <image name> is the name of the image. This will create a bin file that must be renamed to <image name>.SPR before being used with the SF3Patch.

Common Image Descriptions and Information
LOGO.SPR

Width=320 Height=224

Title screen image. 

STTL1.SPR
Width=288 Height=768

Chapter title images. All chapter titles are contained in one image.

ENDLOGO.SPR

Width=320 Height=224
End title "the end" image.
NOWLOAD.SPR
Width-192 Height=32

The "Now Loading..." screen image.
NOWLOAD.SPR with default file path example:

To convert to BMP

bintobmp nowload.spr 192 32

Creates nowload.bmp. Note the spaces between parameters.

To convert back to SPR

bmptobin nowload.bmp

Creates nowload.bin. Rename to NOWLOAD.SPR and place with other patch files in SF3Patch\files.

VII. Contacts and Thanks
Contacts:

legalize freedom!

Project Manager

Email: stvsimms@juno.com
Knight0fDragon 

Project Founder; Patch Software Author/Programmer/Creator, Translation Project Forum Leader

AIM: Knight0fDragon

MSN & Email:dragondolez000@hotmail.com

Special Thanks to:
Cyber Warrior X for partially figuring out the decompressor.

Aho for some image editing and work on the SF3-2 Translation

ark666 for updating the kanji database

Lord Oddeye for finding a lot of the bugs

Moogie and the rest of the SFC boards for support and information,

even though in the beginning it seemed like a lost cause ;-)

Everyone else supporting the cause especially the community at SFC 

Go to www.shiningforcecentral.com for all your shining force info and needs.

Various other SF3 fan sites to help with names and other information

Including but not limited to:

http://www.celestialdamnation.com/jumesyn/
http://rpg-home.lunar-net.com/sf3_new/
SegaXtreme community for help with mkisofs

www.segaxtreme.net
And a small thanks to Sega and Camelot for tempting all other non Japanese speaking people 

with a game that they themselves are forced to translate
